Getting Python >= 3.4
DART-ID is tested on Ubuntu 14.04 (Trusty64) and CentOS 7, but should run on most distros.
The most important step is getting Python >= 3.4, as DART-ID and some of its dependencies will fail to build on earlier versions.
With Ubuntu 14.04, Python3 is not installed by default, and to install you can follow instructions here. Ubuntu 16.10 and above should have Python3 installed by default.
DART-ID does not require the Anaconda/Miniconda environment, but it is useful to have for other reasons. To get Anaconda/Miniconda, follow the instructions here
pip, follow the instructions here
Installing DART-ID and dependencies
python3 -m pip install dart-id
If you are working on a managed machine or computing cluster, you may have to install to your user directory instead of the system python directory. Pass the
--user flag to the install command:
python3 -m pip install dart-id --user